Mmenu.js not loading when utilizing curatescape

While looking into why the Lightbox wasn’t working for my projects images, I noticed in the source that this file mmenu.js was not being pulled in from the server. Not sure if this will fix the Lightbox issue, but it’s still an issue. I have already tried copying the mmenu.js from one of the working curatescape demos to see if my copy of the code was wrong but I’m still hitting the issue. Any idea why I’m experiencing this issue/how to fix it?

Hi, I’m guessing that your site is hosted in a subdirectory, rather than a subdomain or root domain. If that’s the case, you might want to just change the location of your site. But if that’s not possible or if there’s something else going on, let me know with some more details.

Hi @ebell, i’m using a Wordpress site so I’m not doing any of the coding myself. Is there any other way to get this working or do you know where to move it if that is the only option?

Hi, your hosting provider should be able to help you make the changes on your server. You probably won’t need to make any code changes, just change a few things in your hosting account. If your account uses CPanel to administer the server, you can add a subdomain and then choose it as the install location when you install Omeka using Installatron.

:point_down: In CPanel, click Subdomains…

:point_down: Type a subdomain name and choose which root domain to use…

:point_down: Use Installatron to find and install Omeka…

Actual interface may vary a bit depending on your hosting provider.

:point_down: Install Omeka at this new location, leaving the “Directory (Optional)” field blank…

This will create a new installation on your new subdomain. If you already have a lot of content in your existing site that you want to move, you can either export/import the database manually using PHPMyAdmin or use the Omeka API Import plugin.

Again, this is something your hosting provider can help with (and if they have really good support, maybe even do for you).

Hi @ebell, thanks for the info! I have already done all of this when I created my curatescape in the first place. It currently lives as a subdomain of my Wordpress (using C-panel) website.

Hi, if the site is hosed in a subdomain – rather than a subdirectory – the menu and other scripts should load fine. I’m not sure what might be causing the issue. Can you provide a link or a list of error messages from the JavaScript console?

If you’re not sure how to view the console, see instructions here:

Hi @ebell, sorry for taking so long to respond. Here are the screenshots. I tried on both google chrome and safari.

Google Chrome Screenshot

Safari Screenshot

Based on these error messages, it looks like your Curatescape site is trying to load the script from your WordPress website. I don’t know where your Curatescape site is located, but this leads me to believe it’s in a subdirectory. If so, you’ll need to follow the instructions above to move it to a subdomain.

@ebell, I did what you said and created a subdomain. I put all my info on the new subdomain and am still running into all of the same problems, including some new ones. I’ve attached a screenshot of my error messages.

Your site is installed at, which is a subdirectory. If you move it to, that will almost certainly fix this issue.