Description Text for Tours


We are having some issues with the tours function…
We are unable to add description text to existing tours, [the box for text itself is gone].
This is also the case if we were to try to create a new tour.



Hi @sarahkwat, can you check if there are any errors in the Javascript console? Does this happen in any other text fields (e.g. Dublin Core fields for items, etc)? Does this happen in all web browsers?


I’ll look into checking for Javascript errors, but I’m not so familiar with it so make take me a while. The same thing is happening on all browsers.
The error is only in tours- no errors when editing the Dublin Core fields for items.


Can you tell me your Omeka version and the version of the TourBuilder plugin?


Omeka is version 2.6.1
TourBuilder is 1.4


Try upgrading the TourBuilder plugin using the link below…


Hey again!
I downloaded the new tourbuilder plugin and installed it, but when I went to click “upgrade” on the admin side, I get this error message.


Ok, this sounds familiar. There were some upgrade complications a few years back, which affect upgrades of early plugin versions. You may need to comment out 2 lines as depicted in the screenshot below (i.e. add two slashes in front of lines 79 and 80).




ebell - I’m working with sarahk and implementing the changes:

I followed the direction for editing and saving the TourBuilderPlugin.php through my hosting service reclaim
Then I went to the application and tried to upgrade the plugin forTourBuilder
I again got along error message.


Ok, now comment out lines 82 and 83.



Thanks for your help. I’m still having trouble. I followed through with your directions and I created an error message on my homepage so I deleted and retried. Same problem.
You I tried to reintall and when I go to my plugins area of omeka - I get the following:


Here is a temporary link that includes the changes described above. Remove any existing TourBuilder folders from your plugins directory and replace with this (after extracting from zip). Then run the update script.


By “run the update script” what do you mean?
add “//” to lines 79 and 80 as well as 82 and 83?


The version I shared via Dropbox already has those lines commented out.

After deleting the old folders/files, you can log into Omeka and click the Upgrade button at Plugins > Tour Builder.


I got this error message after hitting the upgrade:

There were some old tour that I set up in the old version that I deleted is that the problem?


This is what the omeka plugin page looks like where I hit upgrade - I never seen that _MACOCX “not valid plugin” before


You may need to delete that __MACOSX file/directory using your file manager or FTP client (it might be a hidden file so you may need to make sure that you have enabled “show hidden files”). Not sure how that got in there.

The Upgrade button is what you want to click.

I’m not sure why you’d get the configured PHP path (/usr/bin/php) does not point to a PHP-CLI binary error all of a sudden unless something else in your installation changed.


The _MACOSC file/directory show up everytime that I extract from the zip that you gave me
I delete it and then I get the usual run of error messages again. In the folder you can see the location of the _MACOSX folder


You need to delete the __MACOSX folder from your server. You also need to delete the file from your server.


I did and at upgrade I got the error message again - see screenshot
It this a hosting problem