Trouble with Curatescape Theme Update

Hi Erin and the forum,

Once again, I’ve run into a snag after trying to update Tampa Historical.

The trouble this time started when I noticed that my maps had disappeared. The location pins were there, but floating in a gray box. I searched the forum and found this thread. I followed the instructions and downloaded the newest Curatescape theme. I uploaded it to my FTP and deleted the old version of the Curatescape theme. (There was a strange _MACOSX file that kept appearing in the themes folder whenever I expanded the .zip file – I deleted that, and the zip file as well).

Now, when I go to my site, I get what you see below. The blank space up top is enormous. If I zoom out until the text is illegible, it just keeps going. I get this same big white gray blob on the homepage and any story I click on. If I scroll down, the rest of the page looks fine. The top of the page is just obliterated by the big box.

I’ve deleted and re-uploaded a half a dozen times, but I get the same thing every time. Everything on the admin side looks fine to my un-educated eyes. All the plug-ins are up-to-date. I didn’t notice anything in the theme settings that would account for this.

So, all in all, not a very productive afternoon: I still haven’t solved the map problem, and now the whole site is kinda broken.

Any advice? Thanks!

1 Like

Update: I just checked and it looks fine on the phone. The map works and everything. I’m not sure what would account for that.


This is probably a caching issue. If you use a service like Cloudflare you may need to log in there and delete the cache manually. If not, you might try incrementing the version in theme.ini (changing 3.4.2 to 3.4.2.whatever, which should cause the browser to bypass the cache since the stylesheet URL will have changed.

By the way, the site looks fine on my end, which makes me think it is indeed a caching issue – maybe just in your own browser.

That did it! I had checked the site on two different browsers and had the same problem – turns out I needed to clear the cache in both of them. It’s looking great now, and the map is visible again. Both problems solved. Thanks Erin!

1 Like