The search feature no longer works

I haven’t used my site for a while and I am troubleshooting issues. I posted a question about the map issue earlier. Now, I noticed that the search bar doesn’t work. I get an error. I was looking at the settings there is an option to “Index Records.” It notes that sometimes with an update of Omeka it is necessary to reindex, but when I press the button I get the following error:

UPDATE: I followed the instructions and altered the .htaccess file to uncomment a line.

This is the error now: **Fatal error** : Unparenthesized `a ? b : c ? d : e` is not supported. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)` in **/home/elsberry/public_html/themes/curatescape/search/index.php** on line **41**

To my knowlege, I haven’t made changes to any files.


You likely need to edit the PHP background path in your config files. Below is the documentation for Reclaim Hosting. If you’re using a different host, it might be different.

EDIT: regarding the search error message, you need to update the theme to the latest version, which supports the newer version of PHP that is now in use on your server.

OK, so both of my issues are related to updating the theme. I know that this sounds simplistic, but how do I go about updating the theme without losing everything that I have added so far? What are the steps?

Unless you’ve edited the theme files, updating the theme won’t cause you to “lose” anything. Just replace the old theme folder (at /themes/curatescape) with the newer one. All your settings will remain intact.

You’ll probably also want to update your plugins. And possibly your Omeka installation (instructions).

For the latest theme and plugin versions, see:

I tried that and I lost my background and everything. Would that be because I still need to update the plugins? I have Omeka 3.1.2 installed.

This is what page looks like after the update:

Looks like it’s not loading any theme at all. Check your directory structure and file permissions, make sure the files uploaded fully, etc. Visit the admin side and see what the Appearance section looks like. Does it show an active theme? An error? Can you edit theme settings?

When I uploaded and extracted the theme it nested the Curatescape theme folder inside another Curatescape folder. New dilemma is that it is still not showing correctly, but now the admin login and panel link isn’t visible and I can’t customize the screen.

It is really odd, because the old view flashes briefly then goes away. Update: I cleared my cache and all issues have been resolved.