Navigation menus


#1

I’m having trouble with settings for Navigation menus - I can’t seem to customize the navigation at all. I’ve turned off the “Default Navigation” in the Curatescape theme settings, and have the Navigation settings like this:

but my public page still only lists “Home” “Stories” “Tours” and “About” in the navigation menu

Any suggestions? Am I missing a setting somewhere?


#2

Hi Aaron,

You’ll want to make sure you using the latest versions of the theme (2.3) and Omeka (2.5)? It looks like you may need to update your installation (including Omeka, the theme, and the various plugins).


#3

Also make sure that under the Curatescape theme configuration (under Appearance), you’ve unchecked the box under “Additional Display Options” that says “Default Navigation”


#4

Just to follow up - yes, upgrading Omeka and Curatescape seemed to fix the problems. Thanks!


#5

Hi! Just picking this thread up again: is there a way for us to add one (or more) menu options without toggling back into Omeka’s default navigation? The customized Curatescape menu looks a lot nicer in our instance than the default navigation.


#6

Hi @jimmcg, you might be able to accomplish what you describe by editing the labels in the Omeka navigation settings.


#7

@ebell Thanks! That didn’t do the trick but we might be able to live with the default Omeka menu for now. So there’s no way to manually tweak those aside from un-checking the default navigation option in the theme settings? My only concern is if the project does want to have additional menu options, then the search bar gets stretched out a bit in the banner (see example below).


#8

@jimmcg, I just tested this on your site (I have access since we have a support contract) and it does work.

Have a look at the settings at the following locations and be sure to save changes.

http://rhodetour.org/admin/appearance/edit-navigation

http://rhodetour.org/admin/themes/config?name=curatescape

If you prefer, I can make these changes if you email/DM me the list of links you want to use.


#9

Thanks Erin! It worked once I actually followed the directions! :slight_smile: