Menu Bar broken

Hello, I’ve recently installed curatescape and the menu button doesn’t seem to be working. When I click on it, it takes me here:

I’ve tried toggling the default navigation on and off under the appearance settings with no luck.


Hi @LWieck, you’ll need to host your site in a root domain or subdomain instead of a subdirectory.

So instead of this subdirectory URL …

Use a subdomain like …

Or a root domain like …

This will likely also fix other small issues.

Okay, that makes sense. Is there an easy way to migrate it to the subdomain without setting it up again? (I’m using reclaim hosting / cpanel)

Basically, you’ll just need to create your subdomain and then swap in the new URL in your Installatron/App details in Cpanel under “My Apps.” I’m sure Reclaim will be able to help if you need it.

Hi I’m having the same problem, but I’m not able to move the installation. Is there any other way to get around this issue?

We are planning to map a registered domain onto the current url where it sits at at the moment. If the website were redirected would that fix the issue, or does the directory have to be moved in its entirety?

Hi @james-smith, you should be able to map a subdomain without moving the installation. Mapping either a subdomain or a registered root domain should fix the issue.

That’s good to hear! Thanks for the prompt response. We are only using this url until we sort out a better permanent solution, so I can kill two birds with one stone.

Can I ask as well: is an error when you click on an author name within stories another issue caused by having the install in a subdirectory?


Yep, same error. You’ll see that with tags as well.

By the way, you can also try modifying the .htaccess rules to try to get your server to recognize /omeka as the root of your installation. This can be hit or miss for some reason, but worth a try if you need a quick solution. Either way, it’s generally better to just use a root or subdomain.

As a followup, we ended up moving the directory and it is all working beautifully.

I seem to be facing the same issue with the menubar, plus Photoswipe doesn’t seem to be working either. I’m using the latest release. I have the project installed in a root directory on my server, so that shouldn’t be the issue. Any ideas I could try?

It appears you’re running the theme from a directory named curatescapeupdate. Some of the JS files assume they’re located in a directory named curatescape.

Ah, easy enough – thanks!